読者です 読者をやめる 読者になる 読者になる

かわろぐ

技術、ボルダリング、セキュリティ、その他もろもろ

MENU

dnx を 1.0.0-bata4 から 1.0.0-bata8 へアップデートした時にハマったこと

.net

環境

  • OSX 10.10.5
  • dnvm 1.0.0-bata4 (Homebrew でインストール)

 1.0.0-bata4 から 1.0.0-bata8 へアップデートする

まずはバージョン管理マネージャの dnvm をアップグレードしようと思っておもむろに下記のコマンドを

dnvm update-self

f:id:kawa_xxx:20150927000149p:plain

ところが、自分の環境ではこれでエラーがでたので調べてみると下記の issue に行き着きました。

https://github.com/aspnet/dnvm/issues/246

Homebrewからは移動してこちらのものはもう古いらしいです。

http://docs.asp.net/en/latest/getting-started/installing-on-mac.html

上記URLにしたがって CURLで取得してインストールしました。

dnvm install latest -u

これで dnx dnu ともに 1.0.0-bata8 へアップデート完了! f:id:kawa_xxx:20150927000152p:plain

めでたしめでたし。